Degraded System Performance
Incident Report for Autobooks
Resolved
No further errors have been recorded to our logs since 3:00 PM EST. We'll be working with our partner to understand the root cause of this degraded performance. We apologize for any inconvenience.
Posted Jun 14, 2022 - 15:27 EDT
Investigating
We are currently investigating degraded system performance with the Autobooks application. The Incident Response Team is currently investigating and will have an update within the next hour.
Posted Jun 14, 2022 - 14:52 EDT
This incident affected: Autobooks Platform (API, Web App).