Intermittent P2P Payment Issues

Incident Report for Autobooks

Resolved

This incident has been resolved.
Posted Jul 30, 2026 - 15:16 EDT

Identified

Our P2P service is experiencing intermittent issues. This is not an outage, but occurrences are frequent enough for us to alert on. The root cause is known and a fix is being applied. Subscribe to status alerts for updates. The rest of the Autobooks bill payment platform is operational.
Posted Jul 29, 2026 - 10:52 EDT
This incident affected: Autobooks Payables Platform (Person to Person Payments).