Performance Impact to Payment Creation

Incident Report for Autobooks

Resolved

This incident has been resolved.
Posted Dec 30, 2025 - 13:48 EST

Monitoring

The payables platform is now fully functional. We are continuing to monitor the platform.
Posted Dec 29, 2025 - 17:52 EST

Identified

The team is engaged with resolving the issue affecting payment creation
Posted Dec 29, 2025 - 16:20 EST

Investigating

We are aware of some users experiencing issues attempting to create payments and are actively working to resolve the issue.
Posted Dec 29, 2025 - 12:50 EST
This incident affected: Autobooks Payables Platform (Billpay UI).