Autobooks Receivables Platform Degraded performance

Incident Report for Autobooks

Resolved

This incident has been resolved.
Posted Mar 20, 2026 - 13:11 EDT

Monitoring

The team is actively monitoring the platform for further issues and is not seeing any impact to users as of 11:10.
Posted Mar 20, 2026 - 11:33 EDT

Investigating

The team is engaged with investigating an issue affecting the performance of the Receivables Platform
Posted Mar 20, 2026 - 11:14 EDT
This incident affected: Autobooks Receivables Platform (API).