PortalPay Payments Unavailable

Incident Report for Autobooks

Resolved

This incident has been resolved.
Posted Jul 14, 2025 - 23:46 EDT

Investigating

We are currently investigating this issue.
Posted Jul 14, 2025 - 15:16 EDT
This incident affected: Autobooks Payables Platform (Portal Pay).