Autobooks Temporarily Unavailable

Incident Report for Autobooks

Resolved

Microsoft has resolved the global network issue. The Autobooks receivables application is now fully available.
Posted Oct 29, 2025 - 20:42 EDT

Monitoring

The Autobooks receivables application is now intermittently available as Microsoft continues to resolve the global network issues. Our team is continuing to monitor to ensure that all services fully recover.
Posted Oct 29, 2025 - 17:12 EDT

Update

The Autobooks receivables platform is currently unavailable due to a global Microsoft outage. Our team is continuing to monitor the issue and working to restore services as quickly as possible.
Posted Oct 29, 2025 - 15:28 EDT

Investigating

The team is engaged and is continuing to investigate an Autobooks platform outage resulting from global Microsoft Azure issues.
Posted Oct 29, 2025 - 11:54 EDT
This incident affected: Autobooks Receivables Platform (API, Web App).