ACH Payment Processing
Incident Report for Autobooks
Resolved
This incident has been resolved.
Posted Feb 19, 2023 - 07:44 EST
Update
We are continuing to investigate this issue.
Posted Feb 19, 2023 - 07:44 EST
Update
The issue has been resolved.
Posted Feb 19, 2023 - 03:45 EST
Update
We are continuing to investigate this issue.
Posted Feb 19, 2023 - 02:30 EST
Investigating
We have identified an issue with our ACH provider which is resulting in payment errors in the Autobooks application. As a result, users may receive an error when attempting to submit an ACH payment at this time.
Posted Feb 19, 2023 - 01:57 EST
This incident affected: Autobooks Platform (Web App).