Partial outage for Autobooks Receivables Platform

Incident Report for Autobooks

Resolved

This incident has been resolved.
Posted Aug 25, 2026 - 15:25 EDT

Monitoring

The team has observed broad recovery for the Autobooks Receivables Platform and is monitoring for further issues
Posted Aug 25, 2026 - 14:44 EDT

Identified

The team is engaged with resolving an incident affecting the Autobooks Web Application and API
Posted Aug 25, 2026 - 14:35 EDT
This incident affected: Autobooks Receivables Platform (API, Web App).