We are investigating an issue causing the Hub to be unavailable to some users.
Incident Report for Autobooks
Resolved
The issue impacting Hub availability has been addressed.
Posted Oct 30, 2023 - 16:41 EDT
Investigating
We are currently investigating this issue. This issue is currently not impacting the core Autobooks application.
Posted Oct 30, 2023 - 16:34 EDT
This incident affected: Autobooks Hub.