Customers may encounter issues using Portal Pay, Account to Account, or Person to Person apps

Incident Report for Autobooks

Resolved

The issue has been resolved.
Posted Jun 29, 2025 - 08:56 EDT

Monitoring

A fix has been implemented and payments are successfully processing. The team is continuing to monitor.
Posted Jun 28, 2025 - 12:27 EDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 28, 2025 - 12:12 EDT

Identified

The cause has been identified and the team is working to resolve the issue.
Posted Jun 28, 2025 - 12:11 EDT

Investigating

Some users may encounter issues using Portal Pay, Account to Account, or Person to Person apps. Our team is investigating and will provide additional details as they become available.
Posted Jun 28, 2025 - 11:45 EDT
This incident affected: Autobooks Payables Platform (Portal Pay, Account to Account Transfers, Person to Person Payments).