Person to Person payment failures

Incident Report for Autobooks

Resolved

This incident has been resolved.
Posted Jun 26, 2025 - 17:53 EDT

Monitoring

The team has deployed an update and is monitoring for any further payment failures.
Posted Jun 26, 2025 - 16:01 EDT

Investigating

Our team is currently investigating an issue causing Person to Person payments to fail
Posted Jun 26, 2025 - 13:48 EDT
This incident affected: Autobooks Payables Platform (Billpay UI).