BillPay UI Down

Incident Report for Autobooks

Resolved

This incident has been resolved.
Posted Aug 06, 2026 - 12:22 EDT

Monitoring

A fix has been implemented and we are monitoring the results. All services are operational.
Posted Aug 06, 2026 - 10:54 EDT

Investigating

The team has identified an issue with the Bill Pay application and is currently investigating the issue.
Posted Aug 06, 2026 - 10:25 EDT
This incident affected: Autobooks Payables Platform (Billpay UI, Billpay Admin, Portal Pay, Account to Account Transfers, Person to Person Payments, VisiBill).