ACH Payment Processing
Incident Report for Autobooks
Resolved
We have not seen any errors with payment processing since our ACH provider indicated the issue is resolved.
Posted Feb 15, 2023 - 09:35 EST
Monitoring
Our ACH provider has implemented a fix for their systems and we're now seeing payments process successfully. We'll continue to monitor this situation to ensure everything is back up and running correctly. We apologize for any inconvenience this has caused you or your customers.
Posted Feb 14, 2023 - 22:22 EST
Update
We are continuing to work with our provider to restore ACH payment processing capabilities. Thank you for your patience.
Posted Feb 14, 2023 - 21:16 EST
Investigating
We have identified an issue with our ACH provider which is resulting in payment errors in the Autobooks application. As a result, users may receive an error when attempting to submit an ACH payment at this time. We are actively working with our ACH provider until this incident is resolved.
Posted Feb 14, 2023 - 19:10 EST
This incident affected: Autobooks Platform (Web App).