Customers experiencing issues loading the bill pay application.

Incident Report for Autobooks

Resolved

The incident has been resolved.
Posted Jun 04, 2025 - 17:18 EDT

Monitoring

A fix has been implemented and the team is continuing to monitor the situation.
Posted Jun 04, 2025 - 15:00 EDT

Investigating

Some users may encounter an error when loading the Bill Pay application.
Our team is investigating and will provide additional details as they become available.
Posted Jun 04, 2025 - 14:01 EDT
This incident affected: Autobooks Payables Platform (Billpay UI).