Degraded Bill Pay Performance

Incident Report for Autobooks

Resolved

The team has identified and resolved the issue responsible for the degraded performance on the Autobooks Payables Platform.
Posted May 08, 2026 - 10:37 EDT

Investigating

We are currently experiencing an issue that is causing delays in payment creation.
The team is investigating and will provide an update on this page as soon as possible.
Posted May 08, 2026 - 09:31 EDT
This incident affected: Autobooks Payables Platform (Billpay UI, Portal Pay, Account to Account Transfers, Person to Person Payments).